It is currently Fri Sep 19, 2014 5:51 am




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 
 Modbus Mevices 
Author Message
Cadet
Cadet

Joined: Tue May 29, 2012 11:52 am
Posts: 4
Post Modbus Mevices
I have a project that currently contains 13 devices using Modbus V2 as a driver. Comunications are solid and good. Now I'm trying to add three more Devices, and can not connect to them, I replicated the settings from the ones that are working, but Ignition wont talk to the new devices.
Im able to ping the devices from the computer. Need Help.

Thank you


Thu May 31, 2012 7:03 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2025
Location: Folsom, CA
Post Re: Modbus Mevices
What version of Ignition are you using? Is there anything in the logs? Post the logs.bin.gz file here and we can take a look.

_________________
Kevin Herron
Software Developer
Inductive Automation


Thu May 31, 2012 7:22 am
Profile WWW
Cadet
Cadet

Joined: Tue May 29, 2012 11:52 am
Posts: 4
Post Re: Modbus Mevices
Im usign Ignition Version 7.2.7(b170)
and the Modbus Driver V2
Version 2.2.0-beta5(b97)
Activation Mode Trial.

Where do I find the logs.bin.gz file?


Thu May 31, 2012 8:17 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2025
Location: Folsom, CA
Post Re: Modbus Mevices
I'm not sure if 7.2 has this, but on the Console > Logs tab there's a link to export your logs file that gives you a logs.bin.gz. Otherwise you just need to get your wrapper.log file from the installation directory.

While you're at it you should at least upgrade Ignition to 7.2.10, it might help the troubleshooting.

_________________
Kevin Herron
Software Developer
Inductive Automation


Thu May 31, 2012 8:24 am
Profile WWW
Cadet
Cadet

Joined: Tue May 29, 2012 11:52 am
Posts: 4
Post Re: Modbus Mevices
I tried the export feature and got an exeption report HTTP Status 500.
Then I got the Wrapper file.


Attachments:
wrapper.log [572.26 KiB]
Downloaded 91 times
Thu May 31, 2012 8:51 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2025
Location: Folsom, CA
Post Re: Modbus Mevices  Topic is solved
Your devices (COOK_1, COOK_2, SCALDERS) are refusing the connection. This is happening at a basic TCP level. There's not much more I can tell you, nothing is wrong on the Ignition side.

Perhaps the devices have a limit on the number of incoming connections they can receive or are configured wrong; you'll have to consult your documentation on those devices.

Code:
INFO   | jvm 1    | 2012/05/31 09:49:01 | ERROR [COOK_2                        ] [09:49:01,531]: [COOK_2] Connect Error.
INFO   | jvm 1    | 2012/05/31 09:49:01 | java.net.ConnectException: Connection refused: connect
INFO   | jvm 1    | 2012/05/31 09:49:01 |    at java.net.PlainSocketImpl.socketConnect(Native Method)
INFO   | jvm 1    | 2012/05/31 09:49:01 |    at java.net.PlainSocketImpl.doConnect(Unknown Source)
INFO   | jvm 1    | 2012/05/31 09:49:01 |    at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
INFO   | jvm 1    | 2012/05/31 09:49:01 |    at java.net.PlainSocketImpl.connect(Unknown Source)
INFO   | jvm 1    | 2012/05/31 09:49:01 |    at java.net.SocksSocketImpl.connect(Unknown Source)

_________________
Kevin Herron
Software Developer
Inductive Automation


Thu May 31, 2012 8:55 am
Profile WWW
Cadet
Cadet

Joined: Tue May 29, 2012 11:52 am
Posts: 4
Post Re: Modbus Mevices
Thank you for your help, I will persue this line of troubleshooting.


Thu May 31, 2012 9:05 am
Profile
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 


Who is online

Users browsing this forum: Curlyandshemp and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: