It is currently Sat Aug 23, 2014 9:20 am




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 
 7.5.3 and OSX 
Author Message
Trooper
Trooper

Joined: Sun Jul 15, 2012 9:41 pm
Posts: 28
Post 7.5.3 and OSX
I have 7.5.3 running on a remote machine, which I can access locally and remotely using a windows 7 laptop. When ever I try to connect via my mac running Java 7 it fails to load.

When i click open project, the Java 7 loading box pops up in the centre of the screen and it just stays there for how ever long I let it, until i close java.

Any Ideas? I tried to install Java 6 but not sure how to for OSX. Im running OS X 10.8.2.

Many Thanks.


Sun Oct 28, 2012 10:01 am
Profile
General
General

Joined: Tue May 31, 2011 6:27 am
Posts: 313
Location: Minnesota
Post Re: 7.5.3 and OSX
Try deleting the directory at ~/.ignition to clear all the cache files.


Mon Oct 29, 2012 6:27 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2004
Location: Folsom, CA
Post Re: 7.5.3 and OSX
Java 7u9 on OS X broke webstart. The work-around until Oracle releases a fix is to uninstall Java 7 and revert to the Apple-supplied Java 6.

Instructions on doing so are here:

http://www.java.com/en/download/help/ma ... l_java.xml
http://support.apple.com/kb/HT5559

Sorry for the inconvenience.

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Oct 29, 2012 7:11 am
Profile WWW
Trooper
Trooper

Joined: Sun Jul 15, 2012 9:41 pm
Posts: 28
Post Re: 7.5.3 and OSX
Its no problem, I knew it would be an easy fix :)

Java 6 is now re enabled but I turned off my remote machine as I had no need to access it today, I will test tomorrow and fingers crossed all is now working :)


Mon Oct 29, 2012 2:55 pm
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2004
Location: Folsom, CA
Post Re: 7.5.3 and OSX
If that doesn't work, uninstallling Java 7 and the installing Java 7u7 (and then ignoring the prompts to upgrade to 7u9!!!) also works.

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Oct 29, 2012 2:59 pm
Profile WWW
Cadet
Cadet

Joined: Tue Jul 10, 2012 3:28 pm
Posts: 1
Post Re: 7.5.3 and OSX  Topic is solved
I had the same problem. I got it to work by uninstalling 7u9 and installing 7u7 like Kevin suggested, but I had to run this command to re-enable webstart afterward:

sudo ln -sf /System/Library/Frameworks/JavaVM.framework/Commands/javaws /usr/bin/javaws

After that, all was good!


Thu Nov 01, 2012 6:31 am
Profile
Moderator
Moderator

Joined: Mon Jun 04, 2012 8:53 am
Posts: 440
Post Re: 7.5.3 and OSX
Thanks for the help james.joy, we'll take note of that.

_________________
James Lorenz
QA/Build Systems Engineer
Inductive Automation


Fri Nov 02, 2012 9:49 am
Profile
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: