It is currently Thu Apr 24, 2014 10:35 pm




Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next
 Gateway connection lost frequently, Ignition becomes usuable 
Author Message
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Gateway connection lost frequently, Ignition becomes usuable
At times the gateway connection is lost , then restored so frequently that Ignition becomes unusable.[/b]Connection to gateway lost, due to exception Gateway error 600:

WARN [GatewayConnectionManager-QueryExecuter 4] Connection to Gateway lost, due to exception.
com.inductiveautomation.ignition.client.gateway_interface.GatewayException: Gateway Error 600: Connection refused: connect
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.newGatewayException(GatewayInterface.java:280)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse(GatewayInterface.java:398)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.sendMessage(GatewayInterface.java:219)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.sendMessage(GatewayInterface.java:214)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.runLimitQuery(GatewayInterface.java:586)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.runQuery(GatewayInterface.java:551)
at com.inductiveautomation.factorypmi.application.gateway.SQLQuery.execute(SQLQuery.java:48)
at com.inductiveautomation.factorypmi.application.gateway.QueryManager$Query.execute(QueryManager.java:697)
at com.inductiveautomation.factorypmi.application.gateway.QueryManager$Query.access$500(QueryManager.java:670)
at com.inductiveautomation.factorypmi.application.gateway.QueryManager$QueryExecutor.run(QueryManager.java:314)
at java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at sun.net.NetworkClient.doConnect(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.<init>(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(Unknown Source)
at com.inductiveautomation.ignition.client.gateway_interface.GatewayInterface.getResponse(GatewayInterface.java:303)
... 9 more
INFO [Lew_Disposer_Dash_Board-QueryExecuter 4] Pausing scripts...
INFO [GatewayConnectionManager-QueryExecuter 4] Starting reconnect thread.
ERROR [AbstractPropertyAdapter-AWT-EventQueue-0]


Last edited by Bassafish on Wed Jun 13, 2012 7:42 am, edited 1 time in total.

Wed Jun 13, 2012 7:37 am
Profile
Moderator
Moderator

Joined: Fri Mar 16, 2012 1:00 pm
Posts: 769
Location: Sacramento, CA
Post Re: Gateway connection lost frequently
Can you give us some more information?

Version of Ignition
Version of Java
OS, 32 bit or 64 bit
any other details to include error messages

_________________
Greg Simpson
Inductive Automation
Technical Support Rep


Wed Jun 13, 2012 7:39 am
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes unusabl
version 7.29

64 bit

java 1.6 _ 31


Wed Jun 13, 2012 9:19 am
Profile
Moderator
Moderator

Joined: Fri Mar 16, 2012 1:00 pm
Posts: 769
Location: Sacramento, CA
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Can you upgrade to 7.2.11 and see if that works?

_________________
Greg Simpson
Inductive Automation
Technical Support Rep


Wed Jun 13, 2012 12:24 pm
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Yes I will install it today


Thu Jun 14, 2012 4:22 am
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Running 7.2.11 64 bit . Exact same problem after upgrade, "Gateway Lost Connection errors"

32 clients running, Multiple locations all see the same issues.


Mon Jun 18, 2012 7:17 am
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Why is only Ignition software effected, if it is some kind of a network problem?


Mon Jun 18, 2012 7:19 am
Profile
Corporal
Corporal

Joined: Tue Feb 09, 2010 8:36 pm
Posts: 43
Location: Southwest Colorado, USA
Post Re: Gateway connection lost frequently, Ignition becomes usuable
First thing I check anymore is that someone (or some other software install) didn't install a server using the same TCP ports as Ignition. Once had an IT vendor install IIS role for quickie testing on a server that knocked Ignition out of the game. Was difficult at first to detect what was going on as Ignition's web server and IIS battled it out for access to the port and got errors similar to those you are reporting. Just a thought...


Mon Jun 18, 2012 7:34 am
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
This VM server is dedicated to Ignition.


Mon Jun 18, 2012 8:55 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 1906
Location: Folsom, CA
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Bassafish wrote:
This VM server is dedicated to Ignition.


How much RAM and CPU are allocated to the Ignition VM? How much RAM and CPU does the host machine have? Are you sure you haven't over-allocated the resources? How many VMs are running on this machine?

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Jun 18, 2012 9:05 am
Profile WWW
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
4 ea Xeon 2.27 GHZ
8 gig Ram

Cpu usage 50 - 80%
5 gig ram used


Mon Jun 18, 2012 10:03 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 1906
Location: Folsom, CA
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Bassafish wrote:
4 ea Xeon 2.27 GHZ
8 gig Ram

Cpu usage 50 - 80%
5 gig ram used


Is that the specs of the host machine or the specs of the VM Ignition is running on?

How many VMs are running on the host?

50-80% CPU usage is suspiciously high. Is there a database running on the same VM as well?

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Jun 18, 2012 10:20 am
Profile WWW
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
The spec is for the VM Machine,

Sql server is running with a couple of databases as well as 4 other remote database connections from remote locations.


Mon Jun 18, 2012 10:36 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 1906
Location: Folsom, CA
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Bassafish wrote:
The spec is for the VM Machine,

Sql server is running with a couple of databases as well as 4 other remote database connections from remote locations.



Okay, what resources has the Ignition VM been setup to receive though? And how many other VMs are running on the same host machine?

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Jun 18, 2012 10:42 am
Profile WWW
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Gateway connection lost frequently, Ignition becomes usuable
Please explain (what resources has the Ignition VM been setup to receive though?) what details you want.

I have to go through the Corporate IT group the get the requested details.


Mon Jun 18, 2012 11:20 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next


Who is online

Users browsing this forum: Sergey_D, Serhii and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: