It is currently Sat Apr 19, 2014 11:36 am




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 
 Windows blank in client after using find and replace 
Author Message
General
General

Joined: Thu Jul 31, 2008 2:08 pm
Posts: 386
Location: Chico, CA
Post Windows blank in client after using find and replace
Has anyone else experienced windows being blank on the client after using find and replace on script text?

if i open the window that is blank in the designer and click save and publish the window will display correctly in the client again.

Thanks for the help,

_________________
Jonathan


Wed May 23, 2012 12:18 pm
Profile
Moderator
Moderator

Joined: Sun Apr 02, 2006 2:46 pm
Posts: 4016
Location: Sacramento, CA
Post Re: Windows blank in client after using find and replace
Can you explain how to reproduce this?

_________________
Carl Gould
Software Development
Inductive Automation


Wed May 23, 2012 12:56 pm
Profile WWW
General
General

Joined: Thu Jul 31, 2008 2:08 pm
Posts: 386
Location: Chico, CA
Post Re: Windows blank in client after using find and replace
What i did was i used find on all windows in the project and i searched for "fpmi.nav.centerWindow*"

then i replaced with the string "#removed centerWindow function"

after it finished the replace I saved and published the project. when i opened the client all the components were missing and the startup window was blank.

_________________
Jonathan


Wed May 23, 2012 1:49 pm
Profile
Moderator
Moderator

Joined: Sun Apr 02, 2006 2:46 pm
Posts: 4016
Location: Sacramento, CA
Post Re: Windows blank in client after using find and replace
Hmm, I was unable to reproduce this. Can you copy the project to a test machine and see if it happens again?

_________________
Carl Gould
Software Development
Inductive Automation


Fri May 25, 2012 8:30 am
Profile WWW
General
General

Joined: Thu Jul 31, 2008 2:08 pm
Posts: 386
Location: Chico, CA
Post Re: Windows blank in client after using find and replace
yes it does the same thing on a different machine. i sent an email into support with the project files of before and after the replace.

_________________
Jonathan


Fri May 25, 2012 8:53 am
Profile
Moderator
Moderator

Joined: Fri Dec 04, 2009 9:02 am
Posts: 174
Post Re: Windows blank in client after using find and replace
I have also tried replicating the issue without success. What version of Ignition are you running? Also, when your components disappear can you still see them in the Project Browser hierarchy?


Mon Jun 04, 2012 9:27 am
Profile
General
General

Joined: Thu Jul 31, 2008 2:08 pm
Posts: 386
Location: Chico, CA
Post Re: Windows blank in client after using find and replace
7.4.2

The components are only missing in the client not in the designer. all the windows can be seen fine along with the components in the object browser.

Here is how I can reproduce the problem.

create a project
create a main window that starts on start up
create a button on the window
on the button event action performed put the following code
Code:
system.nav.centerWindow("test")

print "test"

copy the button 3 times any where on the window
close and save the window in the designer
save and publish the project
press F10 to launch the client
login to the client
you will see all the buttons
leave the client open and go back to the designer
open find/replace
find "system.nav.centerWindow"
replace all with with "#system.nav.centerWindow"
save and publish the project
go back to the client
update the client if it does not auto update
now all the button are missing


let me know if it happens for you.

_________________
Jonathan


Tue Jun 05, 2012 3:57 pm
Profile
Moderator
Moderator

Joined: Fri Mar 16, 2012 1:00 pm
Posts: 760
Location: Sacramento, CA
Post Re: Windows blank in client after using find and replace
I have tried to reproduce this issue as well without success. Call Tech Support and reproduce this in GoTo Meeting so we can see what is going on. Without being able to recreate the problem here we cant really help.

_________________
Greg Simpson
Inductive Automation
Technical Support Rep


Wed Jun 06, 2012 7:12 am
Profile
Moderator
Moderator

Joined: Sun Apr 02, 2006 2:46 pm
Posts: 4016
Location: Sacramento, CA
Post Re: Windows blank in client after using find and replace  Topic is solved
Ok we were able to reproduce this with Jonathan's help. It has been fixed for 7.4.4.

_________________
Carl Gould
Software Development
Inductive Automation


Fri Jun 08, 2012 9:58 am
Profile WWW
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: