It is currently Tue Jul 22, 2014 3:22 am




Post new topic Reply to topic  [ 3 posts ] 
 Table headings don't display extended characters 
Author Message
General
General

Joined: Fri Aug 03, 2007 11:39 am
Posts: 626
Location: Devon, England
Post Table headings don't display extended characters
If I try to display extended characters such as the Greek alpha (α) or beta (β) in a table header row, they initially display correctly but are replaced by '?' when the window is saved. If I try to set them from code by creating a new dataset, the characters are replaced by something else e.g. 'α' (code U+03B1) is replaced by '±' (code U+00B1).

Is there any way of displaying extended characters in table headers correctly? They display in labels without a problem.

_________________
Al
DataCapture Ltd.

www.datacap.co.uk


Mon Dec 07, 2009 4:14 am
Profile
General
General

Joined: Thu May 17, 2007 4:56 pm
Posts: 504
Location: Ohio
Post Re: Table headings don't display extended characters
You could use html coding. I just tried displaying phi, and it worked ok:
Code:
<html><i>&#0934</i></html>


Mon Dec 07, 2009 8:07 am
Profile
General
General

Joined: Fri Aug 03, 2007 11:39 am
Posts: 626
Location: Devon, England
Post Re: Table headings don't display extended characters
Step7,

That works excellently well :thumb_left:

For reference, the numbers should be in decimal (rather than the hexadecimal of Unicode), so α is &#945 and β is &#946.

_________________
Al
DataCapture Ltd.

www.datacap.co.uk


Mon Dec 07, 2009 10:16 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: