It is currently Fri Aug 22, 2014 3:48 am




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 
 Connection Lost to Gateway ... Connection Timedout 
Author Message
Cadet
Cadet

Joined: Thu Jun 07, 2012 12:02 pm
Posts: 2
Post Connection Lost to Gateway ... Connection Timedout
We have been getting this error we have six clients attached to a 64 bit IA gateway clients will sparitaclly disconnect from the server go red for a couple seconds and then reconnect...I assumed our switching was bottle necked but I doubt it because it was running fine for months and just recently it started doing this ... we dont know what has changed?

IA support says not enough java sockets? ... how do you even check that?!

jpeterson@kasacompanies.com


Thu Jun 14, 2012 10:47 am
Profile
Cadet
Cadet

Joined: Thu Jun 07, 2012 12:02 pm
Posts: 2
Post Re: Connection Lost to Gateway ... Connection Timedout
A bit more information...

Ignition Gateway is v7.2.11
I attached the client diagnostics log for when the error occurs.
It doesn't log anything in the Gateway Console.
It seems to occur randomly, and never lasts more than a few seconds...
The screen goes gray, and a dialog box appears "Gateway Connection Lost. Connection Timeout."
Then live again.
All of the clients seem to have the error occasionally, but not necessarilly at the same time.
I ran Wireshark and compared to an older file, but did not see any major traffic differences.

I am running out of ideas. What should I check next?


Attachments:
File comment: Client Log for Gateway Lost Error
GatewayLostErr.txt [5.77 KiB]
Downloaded 114 times
Thu Jun 14, 2012 11:09 am
Profile
Moderator
Moderator

Joined: Fri Mar 16, 2012 1:00 pm
Posts: 903
Location: Sacramento, CA
Post Re: Connection Lost to Gateway ... Connection Timedout
Moving thread to Ignition Problems.

_________________
Greg Simpson
Inductive Automation
Technical Support Rep


Thu Jun 14, 2012 12:12 pm
Profile
Moderator
Moderator

Joined: Wed Dec 01, 2010 1:12 pm
Posts: 301
Post Re: Connection Lost to Gateway ... Connection Timedout
I talked with you yesterday. This problem is hard to diagnose due to the number of different factors that can come into play. You were getting socket timeouts showing up in the client log and one of the possible reasons that I said mentioned was port exhaustion on the server. This is by no means the definite cause, it was just an idea for something to look at.

You can view all of the tcp connections on the server several different ways. One way is through the resource monitor which you can get to by opening the taskbar, clicking the performance tab the clicking the Resource Monitor button. The networking tab will show you TCP Connections. You can also download a tool from Microsoft called TCPView which you can get here http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

_________________
Dave Fogle
Technical Support
Inductive Automation


Thu Jun 14, 2012 12:48 pm
Profile
Trooper
Trooper

Joined: Sat Aug 02, 2008 6:03 pm
Posts: 14
Post Re: Connection Lost to Gateway ... Connection Timedout
We are having the same issues of loosing connection to gateway 7.2.11. At times it is so bad that Ignition becomes useless. 32 clients running.

If this can't be fixed, we are going to have to dump Ignition and find some other product that is stable.


Mon Jun 18, 2012 7:13 am
Profile
Moderator
Moderator

Joined: Mon Oct 27, 2008 4:10 pm
Posts: 2004
Location: Folsom, CA
Post Re: Connection Lost to Gateway ... Connection Timedout
Discussion on this topic will continue here.

_________________
Kevin Herron
Software Developer
Inductive Automation


Mon Jun 18, 2012 9:21 am
Profile WWW
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 6 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: